re = /(\\ce(\{(?:[^{}]|(?-1))*?\}))/m
str = '\\displaystyle{\\ce{Cu^{2+}{(aq)}}+\\ce{Zn{(s)}}\\ce{->}\\ce{Cu_{(s)}}+\\ce{Zn^{2+}_{(aq)}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end