// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\\ce(\{(?:[^{}]|(?-1))*?\}))").unwrap();
let string = "\\displaystyle{\\ce{Cu^{2+}{(aq)}}+\\ce{Zn{(s)}}\\ce{->}\\ce{Cu_{(s)}}+\\ce{Zn^{2+}_{(aq)}}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}