use strict;
my $str = '>> -238255238255238255';
my $regex = qr/(?<=-)\d+/p;
my $subst = 'xxx';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";