import Foundation
let pattern = #"(?<=-)\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #">> -238255238255238255"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"xxx"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)