$re = '/(?<=-)\d+/';
$str = '>> -238255238255238255';
$subst = "xxx";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;