package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<minutes>[0-9]|[1-5][0-9]):(?&minutes);`)
var str = `42:24;`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}