$re = '/(?<minutes>[0-9]|[1-5][0-9]):(?&minutes);/';
$str = '42:24;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);