$re = '/(?:(?=\b(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu})/';
$str = 'Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: we A G R E E indeed.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;