#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\n\n?)\n+"
Local $sString = "one return" & @CRLF & _
"" & @CRLF & _
"two returns" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"three returns" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"four returns" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"five returns"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")