package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\n\n?)\n+`)
var str = `one return
two returns
three returns
four returns
five returns`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}