$re = '/(\n\n?)\n+/';
$str = 'one return
two returns
three returns
four returns
five returns';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);