#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\\24((?:.(?!\\24))*:.*?)\\24"
Local $sString = "\24s904dS\24sr4d2\24x\\y\\12z:234F\\3dRl\24o980\24"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")