import re
regex = re.compile(r"\\24((?:.(?!\\24))*:.*?)\\24")
test_str = "\\24s904dS\\24sr4d2\\24x\\\\y\\\\12z:234F\\\\3dRl\\24o980\\24"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")