import Foundation
let pattern = #"\\24((?:.(?!\\24))*:.*?)\\24"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"\24s904dS\24sr4d2\24x\\y\\12z:234F\\3dRl\24o980\24"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}