import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[^>]*<)(\\{\\{[^\\{\\}]*\\}\\})";
final String string = "<div id=\"test\" class=\"test1\">{{message.id}} + a fee</div>\n"
+ "test {{message.body}}";
final String subst = "<span ng-bind=\"$1\"></span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}