re = /(?=[^>]*<)(\{\{[^\{\}]*\}\})/im
str = '<div id="test" class="test1">{{message.id}} + a fee</div>
test {{message.body}}'
subst = '<span ng-bind="$1"></span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result