package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)facebook\.com\/
[^\s?]+
(?:
\.(\d+)\/(\d+)
\S*
|
\?
# Look for 'story_fbid' and 'id' in any order
(?=(?:[^\s&]*?&)*?\bstory_fbid=(\d+))
(?=(?:[^\s&]*?&)*?\bid=(\d+))
\S*
)`)
var str = `https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771
https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605
1.102414276572175
2.460475714099361`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}