import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "facebook\\.com\\/\n"
+ "[^\\s?]+\n"
+ "(?:\n"
+ " \\.(\\d+)\\/(\\d+)\n"
+ " \\S*\n"
+ "|\n"
+ " \\?\n"
+ " # Look for 'story_fbid' and 'id' in any order\n"
+ " (?=(?:[^\\s&]*?&)*?\\bstory_fbid=(\\d+))\n"
+ " (?=(?:[^\\s&]*?&)*?\\bid=(\\d+))\n"
+ " \\S*\n"
+ ")";
final String string = "https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater\n"
+ "https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater\n"
+ "https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771\n"
+ "https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175\n"
+ "https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175\n"
+ "https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605\n\n"
+ "1.102414276572175\n"
+ "2.460475714099361";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}