re = /facebook\.com\/
[^\s?]+
(?:
\.(\d+)\/(\d+)
\S*
|
\?
# Look for 'story_fbid' and 'id' in any order
(?=(?:[^\s&]*?&)*?\bstory_fbid=(\d+))
(?=(?:[^\s&]*?&)*?\bid=(\d+))
\S*
)/mx
str = 'https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771
https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605
1.102414276572175
2.460475714099361'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end