#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2}/\d{2}/\d{4}\b.*\R(?:(?!\d{2}/\d{2}/\d{4}\b).*\R?)*)"
Local $sString = "14/12/2020 12:02:50" & @CRLF & _
"LOG_HERE_1 XXXXX" & @CRLF & _
"" & @CRLF & _
"14/12/2020 12:04:55" & @CRLF & _
"LOG_HERE_2 XXXXX" & @CRLF & _
"" & @CRLF & _
"14/12/2020 12:10:33" & @CRLF & _
"LOG_HERE_3 XXXXX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")