re = /^(\d{2}\/\d{2}\/\d{4}\b.*\R(?:(?!\d{2}\/\d{2}\/\d{4}\b).*\R?)*)/m
str = '14/12/2020 12:02:50
LOG_HERE_1 XXXXX
14/12/2020 12:04:55
LOG_HERE_2 XXXXX
14/12/2020 12:10:33
LOG_HERE_3 XXXXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end