import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2}/\\d{2}/\\d{4}\\b.*\\R(?:(?!\\d{2}/\\d{2}/\\d{4}\\b).*\\R?)*)";
final String string = "14/12/2020 12:02:50\n"
+ "LOG_HERE_1 XXXXX\n\n"
+ "14/12/2020 12:04:55\n"
+ "LOG_HERE_2 XXXXX\n\n"
+ "14/12/2020 12:10:33\n"
+ "LOG_HERE_3 XXXXX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}