$re = '/^(([a-zA-Z]|[0-9])|([-]|[_]|[.]))+[@](([a-zA-Z]|[0-9])|([-]|[_]|[.]))+$/m';
$str = 'bob@bigburger.net
rio_grand@southwest.com
green.planet@wild-west.gov
hopfan123@snq.bnr.beer.com
cdaviso1@vols.utk.edu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);