// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([a-zA-Z]|[0-9])|([-]|[_]|[.]))+[@](([a-zA-Z]|[0-9])|([-]|[_]|[.]))+$").unwrap();
let string = "bob@bigburger.net
rio_grand@southwest.com
green.planet@wild-west.gov
hopfan123@snq.bnr.beer.com
cdaviso1@vols.utk.edu
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}