re = /^(([a-zA-Z]|[0-9])|([-]|[_]|[.]))+[@](([a-zA-Z]|[0-9])|([-]|[_]|[.]))+$/m
str = 'bob@bigburger.net
rio_grand@southwest.com
green.planet@wild-west.gov
hopfan123@snq.bnr.beer.com
cdaviso1@vols.utk.edu
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end