#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d+)"
Local $sString = "Input" & @CRLF & _
"PhoneNumber> (123) 556-7890 PhoneNumber>" & @CRLF & _
"" & @CRLF & _
"Output PhoneNumber>(XXX) XXX-7890 PhoneNumber>" & @CRLF & _
"" & @CRLF & _
"Input" & @CRLF & _
"PhoneNumber> 123 556 7890 PhoneNumber>" & @CRLF & _
"" & @CRLF & _
"Output PhoneNumber>XXX XXX 7890 PhoneNumber>" & @CRLF & _
"" & @CRLF & _
"Input" & @CRLF & _
"PhoneNumber> (123) 556- 7890 PhoneNumber>" & @CRLF & _
"" & @CRLF & _
"Output PhoneNumber>(XXX) XXX- 7890 PhoneNumber>"
Local $sSubst = "x\2x\4x\6x\8x\10x\12\13"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)