use strict;
my $str = 'Input
PhoneNumber> (123) 556-7890 PhoneNumber>
Output PhoneNumber>(XXX) XXX-7890 PhoneNumber>
Input
PhoneNumber> 123 556 7890 PhoneNumber>
Output PhoneNumber>XXX XXX 7890 PhoneNumber>
Input
PhoneNumber> (123) 556- 7890 PhoneNumber>
Output PhoneNumber>(XXX) XXX- 7890 PhoneNumber>';
my $regex = qr/(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d)([() -]*)(\d+)/sp;
my $subst = 'x\\2x\\4x\\6x\\8x\\10x\\12\\13';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";