import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d)([() -]*)(\\d)([() -]*)(\\d)([() -]*)(\\d)([() -]*)(\\d)([() -]*)(\\d)([() -]*)(\\d+)";
final String string = "Input\n"
+ "PhoneNumber> (123) 556-7890 PhoneNumber>\n\n"
+ "Output PhoneNumber>(XXX) XXX-7890 PhoneNumber>\n\n"
+ "Input\n"
+ "PhoneNumber> 123 556 7890 PhoneNumber>\n\n"
+ "Output PhoneNumber>XXX XXX 7890 PhoneNumber>\n\n"
+ "Input\n"
+ "PhoneNumber> (123) 556- 7890 PhoneNumber>\n\n"
+ "Output PhoneNumber>(XXX) XXX- 7890 PhoneNumber>";
final String subst = "x\\2x\\4x\\6x\\8x\\10x\\12\\13";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}