import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![[:punct:]].|\\>|\\w)\\<\\/[p]\\>";
final String string = " <p class=\"calibre_\">John Wiley & Sons Ltd, The Atrium, Southern Gate, Chichester, West Sussex, PO19 8SQ, United Kingdom. </p>\n\n"
+ " <p class=\"calibre_\">For details of our global editorial offices, for customer services and for information about how to apply for permis-</p>\n\n"
+ " <p class=\"calibre_\"><a href=\"http://www.wiley.com\">sion to reuse the copyright material in this book please see our website at www.wiley.com. </a></p>\n\n"
+ " <p class=\"calibre_\">The right of the author to be identified as the author of this work has been asserted in accordance with the </p>";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}