use strict;
my $str = ' <p class="calibre_">John Wiley & Sons Ltd, The Atrium, Southern Gate, Chichester, West Sussex, PO19 8SQ, United Kingdom. </p>
<p class="calibre_">For details of our global editorial offices, for customer services and for information about how to apply for permis-</p>
<p class="calibre_"><a href="http://www.wiley.com">sion to reuse the copyright material in this book please see our website at www.wiley.com. </a></p>
<p class="calibre_">The right of the author to be identified as the author of this work has been asserted in accordance with the </p>';
my $regex = qr/(?<![[:punct:]].|\>|\w)\<\/[p]\>/mip;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";