import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9-]+)(\\.[a-zA-Z]{2,5})?(\\.[a-zA-Z]+$)";
final String string = "domain.com\n"
+ "subdomain.domain.com\n"
+ "sub.sub.subdomain.domain.com\n"
+ "sub.subdomain.com.au\n"
+ "coool.new.domain.luxury";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}