$re = '/([a-zA-Z0-9-]+)(\.[a-zA-Z]{2,5})?(\.[a-zA-Z]+$)/m';
$str = 'domain.com
subdomain.domain.com
sub.sub.subdomain.domain.com
sub.subdomain.com.au
coool.new.domain.luxury';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);