re = /([a-zA-Z0-9-]+)(\.[a-zA-Z]{2,5})?(\.[a-zA-Z]+$)/m
str = 'domain.com
subdomain.domain.com
sub.sub.subdomain.domain.com
sub.subdomain.com.au
coool.new.domain.luxury'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end