using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img .*?src=""[^""]*\/\K([^""]*?\.(?:jpeg|jpg|bmp|gif|png))";
string input = @"<img src=""/assets/images/monitor.png"" style=""float:left; margin-right:10px;"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}