re = /<img .*?src="[^"]*\/\K([^"]*?\.(?:jpeg|jpg|bmp|gif|png))/m
str = '<img src="/assets/images/monitor.png" style="float:left; margin-right:10px;">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end