$re = '/<img .*?src="[^"]*\/\K([^"]*?\.(?:jpeg|jpg|bmp|gif|png))/m';
$str = '<img src="/assets/images/monitor.png" style="float:left; margin-right:10px;">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);