const regex = /(?<=[(,])([^(),]* [^(),]*)(?=[),])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[(,])([^(),]* [^(),]*)(?=[),])', 'gi')
const str = `(AND(OR(SDLC,development life cycle),design,requirements,OR(biztalk,Websphere,TIBCO,Webmethods,ESB,enterprise service bus)))
AND(OR(SDLC,"development life cycle"),OR(banking,AML,anti-money laundering,KYC,know your customer),OR(technology strategy,technical strategy,technical architecture,technology architecture,architect*)`;
const subst = `,"$1")`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);