$re = '/(?<=[(,])([^(),]* [^(),]*)(?=[),])/i';
$str = '(AND(OR(SDLC,development life cycle),design,requirements,OR(biztalk,Websphere,TIBCO,Webmethods,ESB,enterprise service bus)))
AND(OR(SDLC,"development life cycle"),OR(banking,AML,anti-money laundering,KYC,know your customer),OR(technology strategy,technical strategy,technical architecture,technology architecture,architect*)';
$subst = ",\"$1\")";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;