use strict;
my $str = '(AND(OR(SDLC,development life cycle),design,requirements,OR(biztalk,Websphere,TIBCO,Webmethods,ESB,enterprise service bus)))
AND(OR(SDLC,"development life cycle"),OR(banking,AML,anti-money laundering,KYC,know your customer),OR(technology strategy,technical strategy,technical architecture,technology architecture,architect*)';
my $regex = qr/(?<=[(,])([^(),]* [^(),]*)(?=[),])/ip;
my $subst = ',"$1")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";