using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Fields\("")(\w+?)(?=""\)\.Value =)";
string input = @"Fields(""lmlEmployeeID"").Value = oRs.Fields(""lmpEmployeeID"").Value";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}