import re
regex = re.compile(r"\s*eval\(base64_decode\([^\>]*?\)\);")
test_str = (" eval(base64_decode(\"sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa\n\n\n\n\n\n\n\n"
"dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk\"\n\n\n\n"
"));\n"
"));")
subst = "?\\>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)