using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(\d+)(?!.*\d)";
string input = @"GB67 7HG
SHDJK SHDJ896234968 JK899JDKJD
HUOS &78787 HD9045O 8UIURW
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}