$re = '/(.*?)(\d+)(?!.*\d)/';
$str = 'GB67 7HG
SHDJK SHDJ896234968 JK899JDKJD
HUOS &78787 HD9045O 8UIURW
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);