re = /(.*?)(\d+)(?!.*\d)/
str = 'GB67 7HG
SHDJK SHDJ896234968 JK899JDKJD
HUOS &78787 HD9045O 8UIURW
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end