using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=http*).*\/(.*)|(.*?)\/";
string input = @"www.Edmunds.com/Toyota_Camry_Hybrid
http://jido.com
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}