re = /(?=http*).*\/(.*)|(.*?)\//
str = 'www.Edmunds.com/Toyota_Camry_Hybrid
http://jido.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end