$re = '/(?=http*).*\/(.*)|(.*?)\//';
$str = 'www.Edmunds.com/Toyota_Camry_Hybrid
http://jido.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);