package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<it-grid[\n\s\S]*?([\[\(]selectedItems[\]\)])`)
var str = ` <it-grid
[columns]="groupExternalColumns"
[items]="groupExternalItems"
[selection]="groupExternalGridSelection"
[selectedItems]="groupExternalFilterSelection"
(selectedItemsChange)="onSelectedExternalGroupsChanged($event)"
[cellTemplates]="{ nameAndDesc: nameTemplate, settings: settingsTemplate }"
[idPrefix]="'groupExternalSelectorGrid'"
[comparator]="gridPrincipalCompare"
>
<it-grid
class="activities-list activities-list__table"
[selection]="gridSelection"
[paginationOptions]="gridPaginationOptions"
(paginationChanged)="paginationChanged()"
[idPrefix]="'endpointMonitoringListGrid'"
[columns]="endpointMonitoringColumns"
[items$]="endpointMonitoringData$"
[highlightHovered]="true"
[selectedItemNotifier]="selectedConfiguration$"
[cellTemplates]="{
display: displayTemplate
}"
(selectionChange)="onGridSelectionChanged($event)"
(columnRemove)="onGridColumnRemoved($event)"
[useCustomContextMenu]="true"
(customContextMenuClick)="openContextMenu($event)"
(columnFilter)="filterOpen($event)"
>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}