const regex = /<it-grid[\n\s\S]*?([\[\(]selectedItems[\]\)])/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<it-grid[\\n\\s\\S]*?([\\[\\(]selectedItems[\\]\\)])', 'mg')
const str = ` <it-grid
[columns]="groupExternalColumns"
[items]="groupExternalItems"
[selection]="groupExternalGridSelection"
[selectedItems]="groupExternalFilterSelection"
(selectedItemsChange)="onSelectedExternalGroupsChanged(\$event)"
[cellTemplates]="{ nameAndDesc: nameTemplate, settings: settingsTemplate }"
[idPrefix]="'groupExternalSelectorGrid'"
[comparator]="gridPrincipalCompare"
>
<it-grid
class="activities-list activities-list__table"
[selection]="gridSelection"
[paginationOptions]="gridPaginationOptions"
(paginationChanged)="paginationChanged()"
[idPrefix]="'endpointMonitoringListGrid'"
[columns]="endpointMonitoringColumns"
[items\$]="endpointMonitoringData\$"
[highlightHovered]="true"
[selectedItemNotifier]="selectedConfiguration\$"
[cellTemplates]="{
display: displayTemplate
}"
(selectionChange)="onGridSelectionChanged(\$event)"
(columnRemove)="onGridColumnRemoved(\$event)"
[useCustomContextMenu]="true"
(customContextMenuClick)="openContextMenu(\$event)"
(columnFilter)="filterOpen(\$event)"
>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}