use strict;
my $str = ' <it-grid
[columns]="groupExternalColumns"
[items]="groupExternalItems"
[selection]="groupExternalGridSelection"
[selectedItems]="groupExternalFilterSelection"
(selectedItemsChange)="onSelectedExternalGroupsChanged($event)"
[cellTemplates]="{ nameAndDesc: nameTemplate, settings: settingsTemplate }"
[idPrefix]="\'groupExternalSelectorGrid\'"
[comparator]="gridPrincipalCompare"
>
<it-grid
class="activities-list activities-list__table"
[selection]="gridSelection"
[paginationOptions]="gridPaginationOptions"
(paginationChanged)="paginationChanged()"
[idPrefix]="\'endpointMonitoringListGrid\'"
[columns]="endpointMonitoringColumns"
[items$]="endpointMonitoringData$"
[highlightHovered]="true"
[selectedItemNotifier]="selectedConfiguration$"
[cellTemplates]="{
display: displayTemplate
}"
(selectionChange)="onGridSelectionChanged($event)"
(columnRemove)="onGridColumnRemoved($event)"
[useCustomContextMenu]="true"
(customContextMenuClick)="openContextMenu($event)"
(columnFilter)="filterOpen($event)"
>';
my $regex = qr/<it-grid[\n\s\S]*?([\[\(]selectedItems[\]\)])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}